Bug 21389 - [855GM] system freeze on changing to linux console
Summary: [855GM] system freeze on changing to linux console
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: unspecified
Hardware: x86 (IA32) Linux (All)
: medium critical
Assignee: Jesse Barnes
QA Contact: Xorg Project Team
Keywords: NEEDINFO
Depends on:
Reported: 2009-04-24 10:15 UTC by Jens Luedicke
Modified: 2009-06-22 18:56 UTC (History)
0 users

See Also:
i915 platform:
i915 features:

Xorg log (14.00 KB, text/plain)
2009-04-24 10:15 UTC, Jens Luedicke
no flags Details
dmesg (22.20 KB, text/plain)
2009-04-24 10:16 UTC, Jens Luedicke
no flags Details

Description Jens Luedicke 2009-04-24 10:15:46 UTC
Created attachment 25114 [details]
Xorg log

When I change from X11 to a linux console, my system
freezes. The only way out is to turn off and reboot the system.
This happens either on pressing Ctrl-Alt-Fx or on issuing a halt or
reboot command from a x11 terminal.
When suspending the system via acpid script, the system locks
up as well.

The Xorg.0.log is attached.

System: Thinkpad R50e

00:02.0 VGA compatible controller: Intel Corporation 82852/855GM Integrated Graphics Device (rev 02)

Linux kernel
xorg-server 1.6.0
mesa-lib 7.4
Comment 1 Jens Luedicke 2009-04-24 10:16:31 UTC
Created attachment 25115 [details]
Comment 2 Jesse Barnes 2009-05-04 15:49:28 UTC
Does this still happen with 2.6.30-rc4?  Some important 8xx related fixes went in after 2.6.29 came out...
Comment 3 Jens Luedicke 2009-05-05 13:09:38 UTC
I installed 2.6.30-rc4
and I tried xf86-video-intel and 2.7.0

The system still locks up completely when trying to
change to a console. The current root window stays visible,
the mouse pointer disappears. I can't login from remote via ssh.
Comment 4 Jesse Barnes 2009-05-11 11:21:52 UTC
Adjusting severity: crashes & hangs should be marked critical.
Comment 5 Jens Luedicke 2009-05-13 05:16:26 UTC
I tried the new 2.7.1 version of the xf86-video-intel driver.
On Kernel and 2.6.30-rc4.

My system locks up when I change to the console.

btw: If I run Xorg on, the systray icons are not painted
properly. This is just a minor issue (and a different bug).

Comment 6 Jesse Barnes 2009-06-22 18:56:09 UTC
Looks like you don't have the framebuffer console driver loaded or builtin.  Double check CONFIG_FRAMEBUFFER_CONSOLE=y in your kernel config, or that you have fbcon loaded before you load i915 with modeset=1 (also make sure you don't have CONFIG_FB_INTEL enabled at all).  If you've done all that (and attached your .config here) and things are still broken, please re-open.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.