Bug 561

Summary: Multihead Without Xinerama
Product: xorg Reporter: James Kaufman <jmk>
Component: Server/GeneralAssignee: Xorg Project Team <xorg-team>
Severity: normal    
Priority: high CC: erik.andren, mharris
Version: 6.7.0Keywords: want-backtrace
Hardware: x86 (IA32)   
OS: Linux (All)   
See Also: https://bugs.freedesktop.org/show_bug.cgi?id=66724
i915 platform: i915 features:
Description Flags
My complete xorg.conf file none

Description James Kaufman 2004-04-27 09:08:27 UTC
It appears to not work. I have a Matrox G400 AGP and an S3 Inc. ViRGE/DX PCI
card in my system, each connected to a CRT monitor. This snippet from XF86Config
worked under XFree86, but not under xorg:

Section "ServerLayout"

        Identifier     "Multihead layout"
        Screen      0  "Screen0" 0 0
        Screen      1  "Screen1" RightOf "Screen0"
        InputDevice    "Mouse0" "CorePointer"
        InputDevice    "Keyboard0" "CoreKeyboard"
        Option      "Xinerama" "off"
        Option      "Clone" "on"

System just sits there and never displays anything. Using Xinerama works:

Section "ServerLayout"

        Identifier     "Multihead layout"
        Screen      0  "Screen0" 0 0
        Screen      1  "Screen1" RightOf "Screen0"
        InputDevice    "Mouse0" "CorePointer"
        InputDevice    "Keyboard0" "CoreKeyboard"
        Option      "Xinerama" "on"
        Option      "Clone" "off"
Comment 1 Mike A. Harris 2004-07-07 23:17:04 UTC
Using the file attachment link, attach your complete X server config file
to the report for analasis, and someone will investigate.

Comment 2 James Kaufman 2004-07-17 11:44:20 UTC
Created attachment 486 [details]
My complete xorg.conf file

My configuration consists of a primary Matrox G400 (AGP) connected to a
GoldStar StudioWorks 78i monitor, and a S3ViRGE PCI card connected to a CompaQ
MV500 monitor. I want two independent screens. I sometimes watch TV on the
CompaQ monitor and do not want the screen tied to the desktop the Goldstar is

It worked fine under XFree 4.x, but has never worked under Xorg. I have tweaked
many of the options in xorg.conf, but none work. The config I attached has
Xinerama enabled. If I turn Xinerama off, and change nothing else, the system
starts, the green lights on both monitors turn on, then nothing. I have to do a
hard reboot. The system doesn't respond to the keyboard.
Comment 3 Chris Lee 2005-07-04 16:16:48 UTC
Does this still happen with the most recent stable Xorg release? 
Comment 4 Erik Andren 2006-03-10 09:03:25 UTC
I'm closing this bug because of the lack of activity. Please reopen if the bug
exists with a current release of xorg.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.