Bug 28812

Summary: Account.Service: property indicating branded variant of a particular service
Product: Telepathy Reporter: Will Thompson <will>
Component: tp-specAssignee: Will Thompson <will>
Status: RESOLVED FIXED QA Contact: Telepathy bugs list <telepathy-bugs>
Severity: normal    
Priority: medium CC: vivek
Version: unspecifiedKeywords: patch
Hardware: Other   
OS: All   
URL: http://git.collabora.co.uk/?p=user/wjt/telepathy-spec-wjt.git;a=shortlog;h=service
Whiteboard: review+
i915 platform: i915 features:
Bug Depends on:    
Bug Blocks: 28825    

Description Will Thompson 2010-06-29 03:55:55 UTC
Users generally know Google Talk, Ovi Chat, etc. by their brand, not as Jabber or XMPP. Here is a proposed Account property used to indicate this: http://people.freedesktop.org/~wjt/telepathy-spec-service/spec/Account.html#org.freedesktop.Telepathy.Account.Service
Comment 1 Will Thompson 2010-06-29 03:56:40 UTC
And here is the branch!
Comment 2 Will Thompson 2010-06-29 04:07:18 UTC
I have updated the branch to make Service rw, and add a restriction flag.

12:01              wjt | i wonder whether it should instead be read-write so 
                         that Empathy can migrate Facebook and Google Talk 
                         accounts to have that property set appropriately
12:01             smcv | wjt: read-write but with a flag in A.I.Storage for 
                         "actually, no"? :-)
12:02       fledermaus | I was going to say.
12:02              wjt | exactly
Comment 3 Simon McVittie 2010-06-29 04:16:24 UTC
If we or others will use them in object paths or filenames (very likely), then they should have a restricted format; my vote would be /[_A-Za-z][_A-Za-z0-9]+/ or /[A-Za-z][-A-Za-z0-9]+/.

If there's a chance that we might use values of Service in object paths, then it may be worth having their naming convention be like "google_talk".
Comment 4 Will Thompson 2010-06-29 07:06:15 UTC
And updated again to have the same naming rules as protocol names, and to add lj-talk to the well-known list.
Comment 5 Simon McVittie 2010-06-29 08:02:42 UTC

(For the record, the reason GConf was mentioned is that poking GConf via libmissioncontrol was the official way to change parameters in Mission Control 4; there was no D-Bus representation at all.)
Comment 6 Will Thompson 2010-06-29 08:05:24 UTC
Merged; will be in 0.19.8. Thanks!

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.