Bug 25196

Summary: [830] hw cursor lost for 830 card.
Product: Mesa Reporter: alain.prignet
Component: Drivers/DRI/i915Assignee: Jesse Barnes <jbarnes>
Severity: normal    
Priority: medium Keywords: NEEDINFO
Version: unspecified   
Hardware: Other   
OS: All   
i915 platform: i915 features:
Attachments: Xorg.0.log
diff between log with and without DRI

Description alain.prignet 2009-11-20 00:58:51 UTC
Created attachment 31327 [details]

I use a X200 Dell computer with 830 intel graphic card.

For long time (years), I used the software cursor since the hardware one disappears after some time.

With recent xorg, I'm force to use the hardware cursor. It seems that the cursor is lost when "quite" all the RAM is used.

The easiest way is to use gimp with a lot of memory used. I can loose the cursor 3 minutes after X is launched. But I can still have the cursor present for one week (with s2disk hibernation).

I'm using a 2.6.30-2 debian kernel (and recently a 2.6.26-2 one) and a 2.9.0 xorg intel driver. But I know this problem for years.

I have seen nothing in the log.

computer : dell x200 laptop
graphic card : intel 830
uname -m : i686
distribution : debian
kernel : (a lot) 2.6.30-2 debian
libdrm-intel1 : 2.4.14-1+b1
xserver-xorg-video-intel : 2:2.9.0-1
xserver-xorg : 1:7.4+4
Comment 1 alain.prignet 2009-11-20 01:00:09 UTC
Created attachment 31328 [details]
Comment 2 alain.prignet 2009-11-20 02:55:06 UTC
I have made another tests. The loss of the cursor is simpler : I only have to modify the brightness using the keyboard, and I loose the cursor without delay.
Comment 3 alain.prignet 2009-11-20 03:57:33 UTC
I retried the intel driver 2.6.2-1 (from debian) with SWCursor option without halting the computer and I get again a working cursor that does not disappear.
Comment 4 alain.prignet 2009-12-18 09:07:45 UTC
I have tried the driver 2.9.1 (debian version). After having modified the brightness, I still loose the hardware cursor. To retrieve it, I need to reboot the computer if I use the driver with DRI true. But I need only to restart the X server to retrieve it in DRI false mode.

I put in attachement a diff of the two log : with DRI no cursor, without DRI cursor.
Comment 5 alain.prignet 2009-12-18 09:12:01 UTC
Created attachment 32178 [details]
diff between log with and without DRI

with DRI no cursor, without DRI cursor
Comment 6 Jesse Barnes 2010-02-05 14:50:55 UTC
Does this still occur with current kernels and userspace drivers (both Mesa and 2D driver)?  Debian experimental has bits from git, so they should be easy to test.
Comment 7 alain.prignet 2010-02-07 09:47:32 UTC
Sorry, I did not succeed in finding the debian experimental packages for intel driver.

Moreover what do you mean exactly with "current kernels and userspace drivers (both Mesa and 2D driver)"

Comment 8 Jesse Barnes 2010-02-07 10:42:43 UTC
I mean a recent kernel, e.g. 2.6.32.x or 2.6.33-rc, and 2.10 of the xf86-video-intel driver, and a recent version of mesa like 7.7.
Comment 9 Jesse Barnes 2010-04-06 11:22:39 UTC
timeout.  assuming this is fixed or no longer relevant.
Comment 10 alain.prignet 2010-04-18 12:33:41 UTC
I have update my debian testing distribution to 
libdrm-intel1                                2.4.18-3
libdrm2                                      2.4.18-3
xserver-xorg-video-intel                     2:2.9.1-3
xserver-xorg                                 1:7.5+5
xserver-xorg-core                            2:1.7.6-2

and I get still the same problem.

The 2.10 or 2.11 is not even in unstable debian distribution so I cannot test it easily.

Moreover, I have test KMS with 2.9.1, and the screen get blank (registered panic notifier). Since I have read that the non KMS part has been remove from 2.10 xorg driver, I think I will not be able to test anything with a more recent driver.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.