Bug 24537

Summary: -intel pegs CPU, desktop performance suffers after upgrade to 2.9.0
Product: xorg Reporter: Bryce Harrington <bryce>
Component: Driver/intelAssignee: Chris Wilson <chris>
Status: RESOLVED NOTOURBUG QA Contact: Xorg Project Team <xorg-team>
Severity: major    
Priority: high CC: cworth
Version: 7.4 (2008.09)Keywords: NEEDINFO, regression
Hardware: x86 (IA32)   
OS: Linux (All)   
i915 platform: i915 features:
Description Flags
glxinfo.txt none

Description Bryce Harrington 2009-10-14 16:35:56 UTC
Forwarding this bug from Ubuntu reporter dmandell:

Performance regression from 2.8.1 to 2.9.0

[Original Description]
I'd been using Karmic for the last couple of weeks and did an upgrade to get latest last night.  After a reboot I logged in and overall performance was really lousy.  Scrolling from within a window, dragging a window around, typing within a window were glacially slow.  Any time I did any of the above things Xorg pegged the CPU. I tried rebooting again, that didn't work.  I also tried rebooting and using an older kernel, that also didn't work.

What managed to get everything back to normal was reverting from xserver-xorg-video-intel_2%3a2.9.0-1ubuntu2_i386.deb to xserver-xorg-video-intel_2%3a2.8.1-1ubuntu2_i386.deb.  After another reboot performance was as it was before the update.  All other packages remain as they are.

This is (apparently) not related to the cryptsetup version (bug439138), as I don't have it installed:

  Installed: (none)
  Candidate: 2:1.0.6+20090405.svn49-1ubuntu4
  Version table:
     2:1.0.6+20090405.svn49-1ubuntu4 0
        500 http://se.archive.ubuntu.com karmic/main Packages

I'd be glad to help debug this problem, but I probably can't do it during work hours because my laptop is more or less unusable for work while in this state.

Architecture: i386
Date: Wed Oct 14 15:07:05 2009
DistroRelease: Ubuntu 9.10
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
MachineType: LENOVO 6371CTO
Package: xserver-xorg-video-intel 2:2.8.1-1ubuntu2
 Socket 0:
   no product info available
 Socket 0:
   no card
ProcCmdLine: root=UUID=ee48f072-05a2-49ef-989f-a518e7496a51 ro quiet splash vga=794
 PATH=(custom, user)
 ProcVersionSignature: Ubuntu 2.6.31-11.38-generic
 xserver-xorg 1:7.4+3ubuntu5
 libgl1-mesa-glx 7.6.0-1ubuntu4
 libdrm2 2.4.14-1ubuntu1
 xserver-xorg-video-intel 2:2.8.1-1ubuntu2
 xserver-xorg-video-ati 1:6.12.99+git20090929.7968e1fb-0ubuntu1
SourcePackage: xserver-xorg-video-intel
Uname: Linux 2.6.31-11-generic i686
dmi.bios.date: 07/13/2007
dmi.bios.vendor: LENOVO
dmi.bios.version: 7IET30WW (1.11 )
dmi.board.name: 6371CTO
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr7IET30WW(1.11):bd07/13/2007:svnLENOVO:pn6371CTO:pvrThinkPadT60:rvnLENOVO:rn6371CTO:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 6371CTO
dmi.product.version: ThinkPad T60
dmi.sys.vendor: LENOVO
  architecture:       i686kernel:             2.6.31-11-generic
Comment 1 Chris Wilson 2009-10-14 16:54:13 UTC
The immediate suspicion is software fallbacks... Though we've had another report of nearly 100% of the cpu time spinning within the kernel.

Bryce, if you can guide the original reporter through gathering a useful sysprof (debugging symbols for the whole stack is a must!) that would be very useful, thanks.

T60 is i945, correct? Useful to confirm that with lspci.
Comment 2 Bryce Harrington 2009-10-14 17:02:43 UTC
You're right that it is 945:

00:00.0 Host bridge [0600]: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML
and 945GT Express Memory Controller Hub [8086:27a0] (rev 03)
        Subsystem: Lenovo Device [17aa:2017]
00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 945GM/GMS,
943/940GML Express Integrated Graphics Controller [8086:27a2] (rev 03)
        Subsystem: Lenovo Device [17aa:201a]

However from glxinfo doesn't look like SW rendering is in use:

direct rendering: Yes
OpenGL vendor string: Tungsten Graphics, Inc
OpenGL renderer string: Mesa DRI Intel(R) 945GM GEM 20090712 2009Q2 RC3 x86/MMX/SSE2
OpenGL version string: 1.4 Mesa 7.6
Comment 3 Bryce Harrington 2009-10-14 17:03:43 UTC
Created attachment 30425 [details]
Comment 4 Bryce Harrington 2009-10-14 17:04:18 UTC
Created attachment 30426 [details]
Comment 5 Bryce Harrington 2009-10-14 17:04:40 UTC
Created attachment 30427 [details]
Comment 6 Bryce Harrington 2009-10-14 17:06:10 UTC
Created attachment 30428 [details]
Comment 7 Bryce Harrington 2009-10-14 17:06:30 UTC
Created attachment 30429 [details]
Comment 8 Chris Wilson 2009-12-01 14:10:49 UTC
Ah, the critical detail is that the attached Xorg.log is the wrong one! In fact it is for driver version 2.8.0 from the configuration the original reporter reported as working.

The relevant lines of fail from the Xorg.log.old is:

  (EE) intel(0): [drm] Failed to open DRM device for : No such file or directory
  (EE) intel(0): Failed to become DRM master.

causing the driver to fallback to software rendering entirely.

For whatever reason udev has not instantiated the revelant device node, typically /dev/dri/card0, for the module (the i915 module itself is loaded). This sounds like a system configuration issue above and beyond the driver/xserver.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.