Bug 11239

Summary: [945GM] Flicker at 1920x1200 at 60hz on Dell 2407FPW
Product: xorg Reporter: Christopher Warner <christopher.warner>
Component: Driver/intelAssignee: Christopher Warner <christopher.warner>
Status: RESOLVED FIXED QA Contact: Xorg Project Team <xorg-team>
Severity: normal    
Priority: medium CC: cbm, gordon.jin, jrhbcn, michael.fu
Version: 7.2 (2007.02)Keywords: NEEDINFO
Hardware: x86 (IA32)   
OS: Linux (All)   
Whiteboard:
i915 platform: i915 features:
Bug Depends on:    
Bug Blocks: 13027, 13493    
Attachments:
Description Flags
Xorg log
none
Xorg.log with Option "ModeDebug" "true" none

Description Christopher Warner 2007-06-11 15:45:36 UTC
The Screen flickers sporadically at this resolution on a Dell 2407FPW 24 inch panel. This is extremely noticeable when a process requires any major time on the CPU. 

Currently using x.org 7.2.0 as packaged for Ubuntu Fiesty. The modelines cannot be changed here because the LCD panel is connected via vga on the laptop. I haven't tried using a VGA to DVI-D converter as of yet. Other modes are subject to have extremely poor quality as well, 1600x1200 is completely out of focus and blurry. If X log or debugging info is needed i'll attach.
Comment 1 Christopher Warner 2007-06-11 15:46:44 UTC
Created attachment 10261 [details]
Xorg log

Attached log
Comment 2 Javier 2007-07-25 05:09:34 UTC
Not sure if my problem is similar to this one, my glitches occur sporadically at every minute or more, and the flickering is just less than a second were the refresh seems to fail and you can notice the entire screen refreshing. Is this similar to your problem?

I'm using latest git master branch on a Sony vaio with a 945GM chipset. I'm using the VGA connection for a 1280x1024 resolution on an external LCD monitor.
Comment 3 Christopher Warner 2007-07-25 05:35:38 UTC
Yup, that's exactly it. However if I just sit infront of the machine and do absolutely nothing at all; it's fine. The refresh/shake also gets more noticeable as I do anything cpu intensive. I've been living with it for now as most of my cpu intensive work is done on other servers.
Comment 4 Javier 2007-07-31 06:11:38 UTC
It seems to be the same problem then, I've tried both option "XaaNoOffscreenPixmaps" to "true" and "false" (the unique option I've got defined in the device section of my xorg.conf file and I get the same flickering problem. 

I've also updated the intel driver and the drm kernel module to current git (using know xserver version 1.3.0) and the problem persists on my VGA connection at 1280x1024...
Comment 5 Christopher Warner 2007-08-02 08:23:09 UTC
Yeah, I haven't done any debugging myself because this is my work laptop but it sounds like the same issue. Nothing sans breaking down why it's happening will change it. After work slows down a bit and I get sometime I'll try to provide as much debug info as possible, hopefully you'll still be around to test.
Comment 6 Michael Fu 2007-09-27 18:41:33 UTC
we will try to reproduce...
Comment 7 Michael Fu 2007-09-27 21:55:09 UTC
would you please post what the xrandr says of the mode that this monitor support?
Comment 8 Christopher Warner 2007-10-02 13:37:13 UTC
cwarner@cwarner-laptop [~]: xrandr
Screen 0: minimum 320 x 200, current 1920 x 1200, maximum 1920 x 1920
VGA connected 1920x1200+0+0 (normal left inverted right) 519mm x 324mm
   1920x1200tv    60.0*+
   1920x1200      60.0 +
   1600x1200      59.9  
   1680x1050      60.0  
   1280x1024      59.9  
   1024x768       60.0  
   800x600        60.3  
   640x480        60.0  
LVDS connected 1024x768+0+0 (normal left inverted right) 246mm x 185mm
   1024x768       50.0*+   60.0     40.0  
   800x600        60.3  
   640x480        60.0     59.9  
TV disconnected (normal left inverted right)
Comment 9 Christopher Warner 2007-10-31 15:40:14 UTC
--verbose

Screen 0: minimum 320 x 200, current 1920 x 1200, maximum 1920 x 1920
VGA connected 1920x1200+0+0 (0x4f) normal (normal left inverted right) 519mm x 324mm
        Identifier: 0x4c
        Timestamp:  -155037485
        Subpixel:   unknown
        Clones:    
        CRTC:       0
        CRTCs:      0 1
        EDID_DATA:
                00ffffffffffff0010ac16a053523633
                151101030e342178eeee91a3544c9926
                0f5054a54b008180a940714fb3000101
                010101010101283c80a070b023403020
                360007442100001a000000ff00434333
                30323735503336525320000000fc0044
                454c4c20323430375746500a000000fd
                00384c1e5311000a2020202020200025
  1920x1200 (0x4f)  154.0MHz -HSync +VSync
        h: width  1920 start 1968 end 2000 total 2080 skew    0 clock   74.0KHz
        v: height 1200 start 1203 end 1209 total 1235           clock   60.0Hz
  1920x1200tv (0x50)  161.8MHz -HSync -VSync
        h: width  1920 start 2020 end 2052 total 2184 skew    0 clock   74.1KHz
        v: height 1200 start 1202 end 1208 total 1235           clock   60.0Hz
  1600x1200 (0x51)  161.0MHz -HSync +VSync
        h: width  1600 start 1712 end 1880 total 2160 skew    0 clock   74.5KHz
        v: height 1200 start 1203 end 1207 total 1245           clock   59.9Hz
  1680x1050 (0x52)  146.2MHz -HSync +VSync
        h: width  1680 start 1784 end 1960 total 2240 skew    0 clock   65.3KHz
        v: height 1050 start 1053 end 1059 total 1089           clock   60.0Hz
  1280x1024 (0x53)  109.0MHz -HSync +VSync
        h: width  1280 start 1368 end 1496 total 1712 skew    0 clock   63.7KHz
        v: height 1024 start 1027 end 1034 total 1063           clock   59.9Hz
  1024x768 (0x54)   65.0MHz -HSync -VSync
        h: width  1024 start 1048 end 1184 total 1344 skew    0 clock   48.4KHz
        v: height  768 start  771 end  777 total  806           clock   60.0Hz
  800x600 (0x55)   40.0MHz +HSync +VSync
        h: width   800 start  840 end  968 total 1056 skew    0 clock   37.9KHz
        v: height  600 start  601 end  605 total  628           clock   60.3Hz
  640x480 (0x56)   25.2MHz -HSync -VSync
        h: width   640 start  656 end  752 total  800 skew    0 clock   31.5KHz
        v: height  480 start  490 end  492 total  525           clock   60.0Hz
LVDS connected 1024x768+0+0 (0x57) normal (normal left inverted right) 246mm x 185mm
        Identifier: 0x4d
        Timestamp:  -155037485
        Subpixel:   horizontal rgb
        Clones:    
        CRTC:       1
        CRTCs:      1
        EDID_DATA:
                00ffffffffffff0030ae004000000000
                000f010380191278eabd3091544f8b26
                21505421080001010101010101010101
                01010101010128150040410026301888
                3600f6b900000018ed10004041002630
                18883600f6b9000000180000000f0061
                43326143280f010009e50000000000fe
                0048543132315830312d3130310a0077
        BACKLIGHT_CONTROL: 2 (0x00000002) range:  (0,4)
        BACKLIGHT: 34718 (0x0000879e) range:  (0,34718)
  1024x768 (0x57)   54.2MHz -HSync -VSync
        h: width  1024 start 1048 end 1184 total 1344 skew    0 clock   40.3KHz
        v: height  768 start  771 end  777 total  806           clock   50.0Hz
  1024x768 (0x54)   65.0MHz -HSync -VSync
        h: width  1024 start 1048 end 1184 total 1344 skew    0 clock   48.4KHz
        v: height  768 start  771 end  777 total  806           clock   60.0Hz
  1024x768 (0x58)   43.3MHz -HSync -VSync
        h: width  1024 start 1048 end 1184 total 1344 skew    0 clock   32.2KHz
        v: height  768 start  771 end  777 total  806           clock   40.0Hz
  800x600 (0x55)   40.0MHz +HSync +VSync
        h: width   800 start  840 end  968 total 1056 skew    0 clock   37.9KHz
        v: height  600 start  601 end  605 total  628           clock   60.3Hz
  640x480 (0x56)   25.2MHz -HSync -VSync
        h: width   640 start  656 end  752 total  800 skew    0 clock   31.5KHz
        v: height  480 start  490 end  492 total  525           clock   60.0Hz
  640x480 (0x59)   25.2MHz -HSync -VSync
        h: width   640 start  656 end  752 total  800 skew    0 clock   31.5KHz
        v: height  480 start  490 end  492 total  525           clock   59.9Hz
TV disconnected (normal left inverted right)
        Identifier: 0x4e
        Timestamp:  -155037485
        Subpixel:   unknown
        Clones:    
        CRTCs:      0 1
        BOTTOM: 37 (0x00000025) range:  (0,100)
        RIGHT: 46 (0x0000002e) range:  (0,100)
        TOP: 36 (0x00000024) range:  (0,100)
        LEFT: 54 (0x00000036) range:  (0,100)
        TV_FORMAT: NTSC-M
                supported: NTSC-M       NTSC-443     NTSC-J       PAL-M       
                           PAL-N        PAL          480p@59.94Hz 480p@60Hz   
                           576p         720p@60Hz    720p@59.94Hz 720p@50Hz   
                           1080i@50Hz   1080i@60Hz   1080i@59.94H
Comment 10 Michael Fu 2007-11-14 18:38:03 UTC
Keith checked in some fix on PLL clock related code in the last a couple of days.. Would you please help to test if this issue still exist on the tip? thanks.
Comment 11 Christopher Warner 2007-11-15 08:33:17 UTC
I'll roll out a new build for myself sometime in the next couple of days and give it a spin
Comment 12 Christopher Warner 2007-11-29 12:20:28 UTC
The results are not good. It seems at resolutions lower than 1024x768 everything is fine. At 1024x768 or higher there is extreme shake. This is using a pull from git 11-29-2007.

Screen 0: minimum 320 x 200, current 800 x 600, maximum 1920 x 1920
VGA connected 800x600+0+0 (0x64) normal (normal left inverted right) 519mm x 324mm
        Identifier: 0x5c
        Timestamp:  -1930517793
        Subpixel:   unknown
        Clones:    
        CRTC:       0
        CRTCs:      0 1
        EDID_DATA:
                00ffffffffffff0010ac16a053523633
                151101030e342178eeee91a3544c9926
                0f5054a54b008180a940714fb3000101
                010101010101283c80a070b023403020
                360007442100001a000000ff00434333
                30323735503336525320000000fc0044
                454c4c20323430375746500a000000fd
                00384c1e5311000a2020202020200025
  1920x1200 (0x5e)  154.0MHz -HSync +VSync
        h: width  1920 start 1968 end 2000 total 2080 skew    0 clock   74.0KHz
        v: height 1200 start 1203 end 1209 total 1235           clock   60.0Hz
  1920x1200tv (0x5f)  161.8MHz -HSync -VSync
        h: width  1920 start 2020 end 2052 total 2184 skew    0 clock   74.1KHz
        v: height 1200 start 1202 end 1208 total 1235           clock   60.0Hz
  1600x1200 (0x60)  161.0MHz -HSync +VSync
        h: width  1600 start 1712 end 1880 total 2160 skew    0 clock   74.5KHz
        v: height 1200 start 1203 end 1207 total 1245           clock   59.9Hz
  1680x1050 (0x61)  146.2MHz -HSync +VSync
        h: width  1680 start 1784 end 1960 total 2240 skew    0 clock   65.3KHz
        v: height 1050 start 1053 end 1059 total 1089           clock   60.0Hz
  1280x1024 (0x62)  109.0MHz -HSync +VSync
        h: width  1280 start 1368 end 1496 total 1712 skew    0 clock   63.7KHz
        v: height 1024 start 1027 end 1034 total 1063           clock   59.9Hz
  1024x768 (0x63)   65.0MHz -HSync -VSync
        h: width  1024 start 1048 end 1184 total 1344 skew    0 clock   48.4KHz
        v: height  768 start  771 end  777 total  806           clock   60.0Hz
  800x600 (0x64)   40.0MHz +HSync +VSync
        h: width   800 start  840 end  968 total 1056 skew    0 clock   37.9KHz
        v: height  600 start  601 end  605 total  628           clock   60.3Hz
  640x480 (0x65)   25.2MHz -HSync -VSync
        h: width   640 start  656 end  752 total  800 skew    0 clock   31.5KHz
        v: height  480 start  490 end  492 total  525           clock   60.0Hz
LVDS connected (normal left inverted right)
        Identifier: 0x5d
        Timestamp:  -1930517793
        Subpixel:   horizontal rgb
        Clones:    
        CRTCs:      1
        EDID_DATA:
                00ffffffffffff0030ae004000000000
                000f010380191278eabd3091544f8b26
                21505421080001010101010101010101
                01010101010128150040410026301888
                3600f6b900000018ed10004041002630
                18883600f6b9000000180000000f0061
                43326143280f010009e50000000000fe
                0048543132315830312d3130310a0077
        BACKLIGHT_CONTROL: kernel
                supported: native       legacy       combination  kernel      
        BACKLIGHT: 100 (0x00000064) range:  (0,100)
  1024x768 (0x66)   54.2MHz -HSync -VSync
        h: width  1024 start 1048 end 1184 total 1344 skew    0 clock   40.3KHz
        v: height  768 start  771 end  777 total  806           clock   50.0Hz
  1024x768 (0x63)   65.0MHz -HSync -VSync
        h: width  1024 start 1048 end 1184 total 1344 skew    0 clock   48.4KHz
        v: height  768 start  771 end  777 total  806           clock   60.0Hz
  1024x768 (0x67)   43.3MHz -HSync -VSync
        h: width  1024 start 1048 end 1184 total 1344 skew    0 clock   32.2KHz
        v: height  768 start  771 end  777 total  806           clock   40.0Hz
  800x600 (0x64)   40.0MHz +HSync +VSync
        h: width   800 start  840 end  968 total 1056 skew    0 clock   37.9KHz
        v: height  600 start  601 end  605 total  628           clock   60.3Hz
  640x480 (0x65)   25.2MHz -HSync -VSync
        h: width   640 start  656 end  752 total  800 skew    0 clock   31.5KHz
        v: height  480 start  490 end  492 total  525           clock   60.0Hz
  640x480 (0x68)   25.2MHz -HSync -VSync
        h: width   640 start  656 end  752 total  800 skew    0 clock   31.5KHz
        v: height  480 start  490 end  492 total  525           clock   59.9Hz
Comment 13 Hong Liu 2007-12-02 22:30:51 UTC
Searching on dell website, I found the following info
(http://support.dell.com/support/edocs/monitors/2407WFP/en/about.htm#Specifications)

VESA, 1600 x 1200 	75.0 	60.0 	162.0 	+/+
VESA, 1920 x 1200 	74.0 	60.0 	154.0 	+/-

While our driver detects 
1920x1200 (0x5e)  154.0MHz -HSync +VSync
        h: width  1920 start 1968 end 2000 total 2080 skew    0 clock   74.0KHz
        v: height 1200 start 1203 end 1209 total 1235           clock   60.0Hz

So the sync polarity is not correct, so would you please use xrandr to add a new mode to the VGA output (with +hsync -vsync) to see if the problem is solved?

If the above method works, we may need to add a quirk to your monitor then.

Thanks,
Hong
Comment 14 Christopher Warner 2007-12-03 07:40:30 UTC
This looks to have fixed it; I'll be using through out the day to see if there are any major problems. This using the latest git; I'll retard with older drivers from Ubuntu Gutsy release of X to see if it's remedied there as well; just for confirmation purposes.

I created two debug modes; one with the higher freq 193.2MHz and the default detected one with polarity switched as recommended. The first one there is a tiny bit of shake but it's not as noticeable with the 154.0MHz modeline detected things are so far so good!

xrandr --newmode debug1 154.0 1920 1968 2000 2080 1200 1203 1209 1235 +HSync -Vsync
xrandr --addmode VGA debug1
xrandr --output VGA --mode debug1 --verbose --preferred

Comment 15 Christopher Warner 2007-12-03 07:52:14 UTC
This actually maybe an x60 issue itself; I just noticed that on a clean startup the screen shakes as well. It could be that the mode is set wrong by BIOS and the driver detects the incorrect mode. This would have to be reported to Lenovo but just a note should any other bugs for diff laptops report similar behavior.
Comment 16 Hong Liu 2007-12-03 16:42:27 UTC
(In reply to comment #15)
> This actually maybe an x60 issue itself; I just noticed that on a clean startup
> the screen shakes as well. It could be that the mode is set wrong by BIOS and
> the driver detects the incorrect mode. This would have to be reported to Lenovo
> but just a note should any other bugs for diff laptops report similar behavior.
>

The mode added by xrandr is lost the next time you restart your X server.
Currently our driver will probe the EDID data from the monitor to get the modes for the monitor. So most probably the EDID data of this monitor is buggy.
So we need to add a quirk to your monitor to correct the EDID data from this monitor.

Would you please attach the xorg.log with the option ModeDebug on?

Thanks,
Hong
Comment 17 Hong Liu 2007-12-03 17:39:40 UTC
After examining your EDID data, the problem should be fixed by Eric's fix
(commit id: ff4bd3addb48df3eacc4b121cc249a7f38eb981a
Fix the swapped decode of the EDID DTD h/v sync polarity fields)

So would you please try a newer X server with Eric's fix?

Thanks,
Hong
Comment 18 Christopher Warner 2007-12-03 18:15:43 UTC
Will do it's going to take sometime however; i'm gonna be pretty detached for the next two weeks; soon as I'm able to will update.
Comment 19 Michael Fu 2008-01-03 16:52:11 UTC
Christopher´╝î are you able to test to verify?
Comment 20 Christopher Warner 2008-01-04 05:33:18 UTC
Yeah.. i'll try to get to it sometime this afternoon.
Comment 21 Christopher Warner 2008-01-04 11:28:37 UTC
There is sadly still some shaking going on in my latest git pull.. 
Comment 22 Hong Liu 2008-01-06 19:13:41 UTC
(In reply to comment #21)
> There is sadly still some shaking going on in my latest git pull.. 
> 

So with the mode added by xrandr, there is no problem with your monitor?
xrandr --newmode debug1 154.0 1920 1968 2000 2080 1200 1203 1209 1235 +HSync
-Vsync

Would you please attach xorg.log (with modedebug turned on) and output of xrandr --verbose?
Comment 23 Christopher Warner 2008-01-08 06:58:06 UTC
Created attachment 13589 [details]
Xorg.log with Option "ModeDebug" "true"
Comment 24 Christopher Warner 2008-01-08 07:00:03 UTC
Yes, xrandr --newmode debug1 154.0 1920 1968 2000 2080 1200 1203 1209 1235 +HSync -Vsync; works perfectly more me there is no shake and everything is as it should be in this mode.

xrandr --verbose
Screen 0: minimum 320 x 200, current 1920 x 1200, maximum 1920 x 1200
VGA connected 1920x1200+0+0 (0x76) normal (normal left inverted right) 519mm x 324mm
        Identifier: 0x4c
        Timestamp:  1508001950
        Subpixel:   unknown
        Clones:    
        CRTC:       0
        CRTCs:      0 1
        EDID_DATA:
                00ffffffffffff0010ac16a053523633
                151101030e342178eeee91a3544c9926
                0f5054a54b008180a940714fb3000101
                010101010101283c80a070b023403020
                360007442100001a000000ff00434333
                30323735503336525320000000fc0044
                454c4c20323430375746500a000000fd
                00384c1e5311000a2020202020200025
  1920x1200 (0x4f)  154.0MHz -HSync +VSync
        h: width  1920 start 1968 end 2000 total 2080 skew    0 clock   74.0KHz
        v: height 1200 start 1203 end 1209 total 1235           clock   60.0Hz
  1920x1200@60 (0x50)  193.2MHz +HSync -VSync
        h: width  1920 start 2048 end 2256 total 2592 skew    0 clock   74.5KHz
        v: height 1200 start 1201 end 1204 total 1242           clock   60.0Hz
  1600x1200 (0x51)  161.0MHz -HSync +VSync
        h: width  1600 start 1712 end 1880 total 2160 skew    0 clock   74.5KHz
        v: height 1200 start 1203 end 1207 total 1245           clock   59.9Hz
  1680x1050@75 (0x52)  188.1MHz -HSync +VSync
        h: width  1680 start 1800 end 1984 total 2288 skew    0 clock   82.2KHz
        v: height 1050 start 1051 end 1054 total 1096           clock   75.0Hz
  1680x1050@60 (0x53)  147.1MHz -HSync +VSync
        h: width  1680 start 1784 end 1968 total 2256 skew    0 clock   65.2KHz
        v: height 1050 start 1051 end 1054 total 1087           clock   60.0Hz
  1680x1050 (0x54)  146.2MHz -HSync +VSync
        h: width  1680 start 1784 end 1960 total 2240 skew    0 clock   65.3KHz
        v: height 1050 start 1053 end 1059 total 1089           clock   60.0Hz
  1600x1024@60 (0x55)  136.4MHz -HSync +VSync
        h: width  1600 start 1704 end 1872 total 2144 skew    0 clock   63.6KHz
        v: height 1024 start 1025 end 1028 total 1060           clock   60.0Hz
  1280x1024 (0x56)  135.0MHz +HSync +VSync
        h: width  1280 start 1296 end 1440 total 1688 skew    0 clock   80.0KHz
        v: height 1024 start 1025 end 1028 total 1066           clock   75.0Hz
  1280x1024 (0x57)  109.0MHz -HSync +VSync
        h: width  1280 start 1368 end 1496 total 1712 skew    0 clock   63.7KHz
        v: height 1024 start 1027 end 1034 total 1063           clock   59.9Hz
  1440x900@75 (0x58)  136.5MHz -HSync +VSync
        h: width  1440 start 1536 end 1688 total 1936 skew    0 clock   70.5KHz
        v: height  900 start  901 end  904 total  940           clock   75.0Hz
  1440x900@60 (0x59)  106.5MHz -HSync +VSync
        h: width  1440 start 1520 end 1672 total 1904 skew    0 clock   55.9KHz
        v: height  900 start  901 end  904 total  932           clock   60.0Hz
  1280x800@75 (0x5a)  107.2MHz -HSync +VSync
        h: width  1280 start 1360 end 1496 total 1712 skew    0 clock   62.6KHz
        v: height  800 start  801 end  804 total  835           clock   75.0Hz
  1280x800@60 (0x5b)   83.5MHz -HSync +VSync
        h: width  1280 start 1344 end 1480 total 1680 skew    0 clock   49.7KHz
        v: height  800 start  801 end  804 total  828           clock   60.0Hz
  1152x864 (0x5c)  104.0MHz -HSync +VSync
        h: width  1152 start 1224 end 1344 total 1536 skew    0 clock   67.7KHz
        v: height  864 start  867 end  871 total  905           clock   74.8Hz
  1280x768@75 (0x5d)  103.0MHz -HSync +VSync
        h: width  1280 start 1360 end 1496 total 1712 skew    0 clock   60.2KHz
        v: height  768 start  769 end  772 total  802           clock   75.0Hz
  1280x768@60 (0x5e)   80.1MHz -HSync +VSync
        h: width  1280 start 1344 end 1480 total 1680 skew    0 clock   47.7KHz
        v: height  768 start  769 end  772 total  795           clock   60.0Hz
  1280x720@60 (0x5f)   74.5MHz -HSync +VSync
        h: width  1280 start 1336 end 1472 total 1664 skew    0 clock   44.8KHz
        v: height  720 start  721 end  724 total  746           clock   60.0Hz
  1024x768 (0x60)   78.8MHz +HSync +VSync
        h: width  1024 start 1040 end 1136 total 1312 skew    0 clock   60.1KHz
        v: height  768 start  769 end  772 total  800           clock   75.1Hz
  1024x768 (0x61)   65.0MHz -HSync -VSync
        h: width  1024 start 1048 end 1184 total 1344 skew    0 clock   48.4KHz
        v: height  768 start  771 end  777 total  806           clock   60.0Hz
  800x600@72 (0x62)   50.0MHz +HSync +VSync
        h: width   800 start  856 end  976 total 1040 skew    0 clock   48.1KHz
        v: height  600 start  637 end  643 total  666           clock   72.2Hz
  800x600@75 (0x63)   49.5MHz +HSync +VSync
        h: width   800 start  816 end  896 total 1056 skew    0 clock   46.9KHz
        v: height  600 start  601 end  604 total  625           clock   75.0Hz
  800x600 (0x64)   49.5MHz +HSync +VSync
        h: width   800 start  816 end  896 total 1056 skew    0 clock   46.9KHz
        v: height  600 start  601 end  604 total  625           clock   75.0Hz
  800x600@60 (0x65)   40.0MHz +HSync +VSync
        h: width   800 start  840 end  968 total 1056 skew    0 clock   37.9KHz
        v: height  600 start  601 end  605 total  628           clock   60.3Hz
  800x600 (0x66)   40.0MHz +HSync +VSync
        h: width   800 start  840 end  968 total 1056 skew    0 clock   37.9KHz
        v: height  600 start  601 end  605 total  628           clock   60.3Hz
  800x600@56 (0x67)   36.0MHz +HSync +VSync
        h: width   800 start  824 end  896 total 1024 skew    0 clock   35.2KHz
        v: height  600 start  601 end  603 total  625           clock   56.2Hz
  640x480 (0x68)   31.5MHz -HSync -VSync
        h: width   640 start  656 end  720 total  840 skew    0 clock   37.5KHz
        v: height  480 start  481 end  484 total  500           clock   75.0Hz
  640x480 (0x69)   25.2MHz -HSync -VSync
        h: width   640 start  656 end  752 total  800 skew    0 clock   31.5KHz
        v: height  480 start  490 end  492 total  525           clock   60.0Hz
  720x400 (0x6a)   28.3MHz -HSync +VSync
        h: width   720 start  738 end  846 total  900 skew    0 clock   31.5KHz
        v: height  400 start  412 end  414 total  449           clock   70.1Hz
  debug1 (0x76)  154.0MHz +HSync -VSync
        h: width  1920 start 1968 end 2000 total 2080 skew    0 clock   74.0KHz
        v: height 1200 start 1203 end 1209 total 1235           clock   60.0Hz
LVDS connected 1024x768+0+0 (0x6b) normal (normal left inverted right) 246mm x 185mm
        Identifier: 0x4d
        Timestamp:  1508001950
        Subpixel:   horizontal rgb
        Clones:    
        CRTC:       1
        CRTCs:      1
        EDID_DATA:
                00ffffffffffff0030ae004000000000
                000f010380191278eabd3091544f8b26
                21505421080001010101010101010101
                01010101010128150040410026301888
                3600f6b900000018ed10004041002630
                18883600f6b9000000180000000f0061
                43326143280f010009e50000000000fe
                0048543132315830312d3130310a0077
        BACKLIGHT_CONTROL: 2 (0x00000002) range:  (0,4)
        BACKLIGHT: 34718 (0x0000879e) range:  (0,34718)
  1024x768 (0x6b)   54.2MHz -HSync -VSync
        h: width  1024 start 1048 end 1184 total 1344 skew    0 clock   40.3KHz
        v: height  768 start  771 end  777 total  806           clock   50.0Hz
  1024x768 (0x61)   65.0MHz -HSync -VSync
        h: width  1024 start 1048 end 1184 total 1344 skew    0 clock   48.4KHz
        v: height  768 start  771 end  777 total  806           clock   60.0Hz
  1024x768 (0x6c)   43.3MHz -HSync -VSync
        h: width  1024 start 1048 end 1184 total 1344 skew    0 clock   32.2KHz
        v: height  768 start  771 end  777 total  806           clock   40.0Hz
  800x600 (0x66)   40.0MHz +HSync +VSync
        h: width   800 start  840 end  968 total 1056 skew    0 clock   37.9KHz
        v: height  600 start  601 end  605 total  628           clock   60.3Hz
  640x480 (0x69)   25.2MHz -HSync -VSync
        h: width   640 start  656 end  752 total  800 skew    0 clock   31.5KHz
        v: height  480 start  490 end  492 total  525           clock   60.0Hz
  640x480 (0x6d)   25.2MHz -HSync -VSync
        h: width   640 start  656 end  752 total  800 skew    0 clock   31.5KHz
        v: height  480 start  490 end  492 total  525           clock   59.9Hz
TV disconnected (normal left inverted right)
        Identifier: 0x4e
        Timestamp:  1508001950
        Subpixel:   unknown
        Clones:    
        CRTCs:      0 1
        BOTTOM: 37 (0x00000025) range:  (0,100)
        RIGHT: 46 (0x0000002e) range:  (0,100)
        TOP: 36 (0x00000024) range:  (0,100)
        LEFT: 54 (0x00000036) range:  (0,100)
        TV_FORMAT: NTSC-M
                supported: NTSC-M       NTSC-443     NTSC-J       PAL-M       
                           PAL-N        PAL          480p@59.94Hz 480p@60Hz   
                           576p         720p@60Hz    720p@59.94Hz 720p@50Hz   
                           1080i@50Hz   1080i@60Hz   1080i@59.94H
Comment 25 Hong Liu 2008-01-08 17:43:42 UTC
(In reply to comment #21)
> There is sadly still some shaking going on in my latest git pull.. 
> 

Just want to make sure, you have pulled X server not just driver...
Comment 26 Christopher Warner 2008-01-09 08:27:14 UTC
Errr just pulled driver.. i'll pull X down and try if not today, tomorrow when I get some free time.
Comment 27 Benjamin Close 2008-01-11 02:38:39 UTC
Bugzilla Upgrade Mass Bug Change

NEEDSINFO state was removed in Bugzilla 3.x, reopening any bugs previously listed as NEEDSINFO.

  - benjsc
    fd.o Wrangler
Comment 28 Gordon Jin 2008-01-13 21:52:28 UTC
re-assigning to the reporter for answer, since NEEDINFO gone.
Comment 29 Michael Fu 2008-01-29 22:28:10 UTC
(In reply to comment #26)
> Errr just pulled driver.. i'll pull X down and try if not today, tomorrow when
> I get some free time.
> 

Hi, Christopher any update?
Comment 30 Christopher Warner 2008-01-30 08:14:27 UTC
(In reply to comment #29)
> (In reply to comment #26)
> > Errr just pulled driver.. i'll pull X down and try if not today, tomorrow when
> > I get some free time.
> > 
> 
> Hi, Christopher any update?
> 

Yeah still haven't had the time to get this done.. Here at nymag this is a really busy time as fashion week is about two days away. The problem is this laptop is where I do all of my work so compiling X is currently on the back burner for me. I promise soon as I get some downtime to build. 
Comment 31 Hong Liu 2008-02-14 01:02:21 UTC
I am closing this bug since it's fixed in the Xorg server.

Please reopen it if problem still existes.

Thanks,
Hong

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.