Bug 10922

Summary: kde-window-decorator crash
Product: xorg Reporter: john frey <john>
Component: App/compizAssignee: David Reveman <reveman>
Status: RESOLVED WORKSFORME QA Contact: Xorg Project Team <xorg-team>
Severity: major    
Priority: medium Keywords: have-backtrace
Version: 7.1 (2006.05)   
Hardware: x86-64 (AMD64)   
OS: Linux (All)   
Whiteboard:
i915 platform: i915 features:

Description john frey 2007-05-12 00:07:49 UTC
Occurs frequently (maybe every 3-4hrs) I have not been able to determine a pattern to the crashes.  Restarting the x-server fixes it temporarily.  In searching bug reports I ran across this thread http://bugs.kde.org/show_bug.cgi?id=143419.  The same problem but I have a different backtrace.

(no debugging symbols found)
Using host libthread_db library "/lib64/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 47110423780192 (LWP 21765)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
0x00002ad8bfc6e2b0 in nanosleep () from /lib64/libc.so.6
#0  0x00002ad8bfc6e2b0 in nanosleep () from /lib64/libc.so.6
#1  0x00002ad8bfc6e0e9 in sleep () from /lib64/libc.so.6
#2  0x00002ad8bada29bc in KCrash::startDrKonqi ()
   from /usr/lib64/libkdecore.so.4
#3  0x00002ad8badb5c34 in KCrash::defaultCrashHandler ()
   from /usr/lib64/libkdecore.so.4
#4  0x00002ad8bfc08da0 in QWidget::setUpdatesEnabled () from /lib64/libc.so.6
#5  0x0000000000000000 in ?? ()

I can regain the window decorations by typing  "kde-window-decorator --replace &". 

OS  Mandriva 2007.1
Comment 1 Daniel Hahler 2007-09-23 15:42:10 UTC
I've added a more useful backtrace over at launchpad:
https://bugs.launchpad.net/compiz/+bug/129801
Comment 2 Kristian LyngstĂžl 2009-02-06 14:58:11 UTC
This code has been changed a bit since this bug report. Please reopen this bug at bugs.opencompositing.org if you still experience it. Sorry for the inconvenience.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.