Bug 102340

Summary: [HSW] uncleared fifo underrun on pipe A and CPU pipe A FIFO underrun error at boot time
Product: DRI Reporter: Mahfuz <burhansylhet>
Component: DRM/IntelAssignee: Intel GFX Bugs mailing list <intel-gfx-bugs>
Status: CLOSED FIXED QA Contact: Intel GFX Bugs mailing list <intel-gfx-bugs>
Severity: normal    
Priority: medium CC: intel-gfx-bugs, philippe
Version: unspecifiedKeywords: bisect_pending
Hardware: x86-64 (AMD64)   
OS: Linux (All)   
Whiteboard: ReadyForDev
i915 platform: HSW i915 features: display/Other
Description Flags
4.12.8-2-ARCH dmesg with drm.debug=0xe
Mainline with uname and dmesg
dmesg 4.14.0-rc6-mainline none

Description Mahfuz 2017-08-21 16:37:19 UTC
Created attachment 133646 [details]
4.12.8-2-ARCH dmesg with drm.debug=0xe

After the upgrade to 4.12 I get following while booting

[drm:intel_set_cpu_fifo_underrun_reporting [i915]] *ERROR* uncleared fifo underrun on pipe A
[drm:intel_cpu_fifo_underrun_irq_handler [i915]] *ERROR* CPU pipe A FIFO underrun

Laptop: HP 15 notebook PC. Kernel 4.11, 4.10, 4.9 work fine without errors.

uname -a:
Linux Extreme 4.12.8-2-ARCH #1 SMP PREEMPT Fri Aug 18 14:08:02 UTC 2017 x86_64 GNU/Linux
Comment 1 Mahfuz 2017-08-21 16:39:51 UTC
Created attachment 133647 [details]
Mainline with uname and dmesg
Comment 2 Elizabeth 2017-08-21 22:31:49 UTC
Adding tag into "Whiteboard" field - ReadyForDev
*Status is correct
*Platform is included
*Feature is included
*Priority and Severity correctly set
*Logs included
Comment 3 Elizabeth 2017-10-25 17:10:21 UTC
Hello Mahfuz, any change with latest tip or mainline? Thanks.

Comment 4 Mahfuz 2017-10-28 09:00:55 UTC
Created attachment 135141 [details]
dmesg 4.14.0-rc6-mainline

Seems like this is fixed in mainline.
Comment 5 Mahfuz 2018-01-08 16:12:28 UTC
Kernel 4.14.12 brings the same problem for my (same) device. Up until 4.14.11 , things worked fine.
Comment 6 Elizabeth 2018-01-08 20:38:08 UTC
(In reply to Mahfuz from comment #5)
> Kernel 4.14.12 brings the same problem for my (same) device. Up until
> 4.14.11 , things worked fine.
Could you try to bisect between 4.14.11 and 4.14.12?
Comment 7 Jani Saarinen 2018-03-29 07:11:47 UTC
First of all. Sorry about spam.
This is mass update for our bugs. 

Sorry if you feel this annoying but with this trying to understand if bug still valid or not.
If bug investigation still in progress, please ignore this and I apologize!

If you think this is not anymore valid, please comment to the bug that can be closed.
If you haven't tested with our latest pre-upstream tree(drm-tip), can you do that also to see if issue is valid there still and if you cannot see issue there, please comment to the bug.
Comment 8 Mahfuz 2018-04-08 12:37:41 UTC
I was in remote location , I'll update within a week.
Comment 9 Mahfuz 2018-04-15 14:41:53 UTC
This doesn't happen with 4.15.
Comment 10 Jani Saarinen 2018-04-16 07:40:59 UTC
OK, thanks for the feedback, closing.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.